resume/flake.nix

48 lines
1.1 KiB
Nix

{
inputs = {
nixpkgs.url = "github:nixos/nixpkgs";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = {
self,
flake-utils,
nixpkgs,
}:
flake-utils.lib.eachDefaultSystem (
system: let
pkgs = nixpkgs.legacyPackages.${system};
in {
packages.default = pkgs.stdenv.mkDerivation {
pname = "resume";
version = "typst";
src = ./.;
nativeBuildInputs = with pkgs; [
typst
raleway
];
buildPhase = ''
runHook preBuild
mkdir $out
export TYPST_FONT_PATHS=${pkgs.raleway}/share/fonts
typst compile resume.typ $out/resume.pdf
typst compile resume.typ $out/resume.png
cp resume.typ $out/resume.typ
runHook postBuild
'';
};
devShells.default = pkgs.mkShell {
nativeBuildInputs = with pkgs; [
typst
raleway
];
shellHook = ''
export TYPST_FONT_PATHS=${pkgs.raleway}/share/fonts
'';
};
}
);
}